Back
Maintenance
Maintenance
Database update
Completed 21 Feb at 01:40am EET.
Completed
Maintenance completed
Posted
21 Feb at 01:40am EET.
Updated
The update is taking longer than expected but we should be back online within the next hour.
Posted
21 Feb at 01:06am EET.
Started
We're updating our database servers, this will cause some interruptions to the services but the maintenance is expected to take less than an hour.
Posted
21 Feb at 12:00am EET.